Popular Posts

Tuesday 30 June 2015

Practical Exercise: OSPF and RIP Redistribution

Configure the network in Figure 4-8 for OSPF between the three routers named SanFran, Mel, and Simon. Configure the edge router named Sydney for RIP and ensure IP connectivity among all four routers. You must use only RIPv1 and OSPF as your IP routing protocols. Ensure that a default route appears on all routers so users can connect to the Internet. Configure summarization wherever possible to minimize IP routing tables.
04fig08.gif
Figure 4-8 -to- Redistribution

Practical Exercise Solution

The router named Simon is configured in the OSPF area 0 (backbone) and the RIP domain and needs to run redistribution between OSPF and OSPF. Also, because you are using RIPv1, you must also provide summary addresses for all networks, but not /24 because RIPv1 does not carry subnet mask information in routing updates. (RIPv2 does).
Router SanFran is connected to the Internet, so you need to configure SanFran to provide a default route to the rest of the internal network by using the OSPF command default-information originate always. This IOS command injects a default route into the OSPF domain and Router Simon because redistribution also injects a default route into the RIP domain.
The following are the full working configurations of all four routers with the shaded portions highlighting critical configuration commands. Example 4-60 displays the full working configuration of Router Sydney. Sydney is running RIP only.

Example 4-60. Full Working Configuration of Router Sydney

hostname Sydney
!
logging buffered 64000 debugging
enable password cisco
!
ip subnet-zero
no ip domain-lookup
interface Ethernet0/0
 ip address 141.108.1.1 255.255.255.0
 no ip directed-broadcast
!
interface Serial0/0
 shutdown
!
interface Serial0/1
 shutdown
!
router rip
 network 141.108.0.0
!
line con 0
line aux 0
line vty 0 4
!
end
Example 4-61 displays the full working configuration of Router Simon. Simon is running OSPF and RIP. You must always be careful when redistributing information from one routing domain into another. Simon advertises the non /24 subnets as Class C networks so the RIP domain (Sydney router) can inject them into the routing table. Because RIPv1 is classless and the subnet 141.108.1.0/24 is configured locally, all interfaces in this Class B network (141.108.0.0) are assumed to be Class C.

Example 4-61. Full Working Configuration of Router Simon

Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Simon
!
enable password cisco
!
ip subnet-zero
no ip domain-lookup
!
cns event-service server
!
interface Ethernet0
 ip address 141.108.2.1 255.255.255.128
!
interface Ethernet1
 ip address 141.108.1.4 255.255.255.0
!
interface Serial0
 shutdown
!
interface Serial1
 shutdown
!
interface Serial2
 ip address 141.108.255.5 255.255.255.252
 clockrate  128000
!
interface Serial3
 ip address 141.108.255.1 255.255.255.252
 clockrate  128000
!
router ospf 1
 summary-address 141.108.2.0 255.255.255.0
 summary-address 141.108.255.0 255.255.255.0
 summary-address 141.108.3.0 255.255.255.0
 summary-address 141.108.4.0 255.255.255.0
 redistribute connected subnets
 redistribute rip metric 10 subnets
 network 141.108.2.0 0.0.0.127 area 0
 network 141.108.255.0 0.0.0.255 area 0
!
router rip
 redistribute ospf 1 metric 2
 passive-interface Ethernet0 -> Stops RIP updates on OSPF interfaces
 passive-interface Serial2
 passive-interface Serial3
 network 141.108.0.0
!
=
ip route 141.108.3.0 255.255.255.0 Null0
ip route 141.108.4.0 255.255.255.0 Null0
!
line con 0
line aux 0
line vty 0 4
!
end
Example 4-62 displays the full working configuration of Router Mel. Mel is running OSPF only.

Example 4-62. Full Working Configuration of Router Mel

hostname Mel
enable password cisco
!
ip subnet-zero
no ip domain-lookup
!
interface Ethernet0
 ip address 141.108.3.1 255.255.255.248
!
interface Serial0
 ip address 141.108.255.6 255.255.255.252
!
interface Serial1
 shutdown
!
router ospf 1
network 141.108.0.0 0.0.255.255 area 0
!
line con 0
line 1 8
line aux 0
line vty 0 4
!
end
Example 4-63 displays the full working configuration of Router SanFran. SanFran has a default static route pointing to Serial 1, which is the Internet connection. Under the routing OSPF process, this default route is injected by using the default-information originate always command.

Example 4-63. Full Working Configuration of Router SanFran

hostname SanFran
!
no ip domain-lookup
!
interface Ethernet0
 ip address 141.108.4.1 255.255.255.240
!
interface Serial0
 ip address 141.108.255.2 255.255.255.252
!
interface Serial1
 shutdown
!
router ospf 1
 network 141.108.0.0 0.0.255.255 area 0
 default-information originate always
!
ip route 0.0.0.0 0.0.0.0 Serial1
!
line con 0
line aux 0
line vty 0 4
!
end

No comments: